dubbo-admin JDK8的问题

dubbo-admin JDK8的问题

五月 06, 2016

fixed:https://github.com/alibaba/dubbo/issues/50

dubbo-admin到2.5.4版本为止,不支持JDK8,解决如下:

webx的依赖改为3.1.6版

1
2
3
4
5
<dependency>
<groupId>com.alibaba.citrus</groupId>
<artifactId>citrus-webx-all</artifactId>
<version>3.1.6</version>
</dependency>

添加velocity的依赖,使用1.7版本以上

1
2
3
4
5
<dependency>
<groupId>org.apache.velocity</groupId>
<artifactId>velocity</artifactId>
<version>1.7</version>
</dependency>

对依赖项dubbo添加exclusion,避免引入旧spring

1
2
3
4
5
6
7
8
9
10
11
<dependency>
<groupId>com.alibaba</groupId>
<artifactId>dubbo</artifactId>
<version>${project.parent.version}</version>
<exclusions>
<exclusion>
<groupId>org.springframework</groupId>
<artifactId>spring</artifactId>
</exclusion>
</exclusions>
</dependency>

webx已有spring 3以上的依赖,因此注释掉dubbo-admin里面的spring依赖

1
2
3
4
<!--<dependency>-->
<!--<groupId>org.springframework</groupId>-->
<!--<artifactId>spring</artifactId>-->
<!--</dependency>-->